遇到问题第一个就是上网寻找帮助,发现有人说flutter doctor就解决了,但flutter doctor并没有显示有任何问题。

具体问题如下:

clang: error: linker command failed with exit code 1 (use -v to see invocation)

note: Using new build system

note: Building targets in parallel

note: Planning build

note: Constructing build description

warning: no rule to process file 'xxx' of type 'text' for architecture 'x86_64' (in target 'xxx' from project 'Pods')

 Could not build the application for the simulator.
 Error launching application on iPhone 11 Pro.

经过多次 关键字 变更搜索后,终于找着问题解决方法了
问题是:framework not found Flutter
解决:查看配置路径,找到flutter.framework,添加flutter库

1、

frc 3d6788e7f61cdf71fa49993c48666ee6 - flutter更新遇到ld: framework not found Flutter
出问题的文件路径

2、解压包

frc edaf5aa15d7287e2b4b6a1bf08d4b7c7 - flutter更新遇到ld: framework not found Flutter
双击压缩包把Flutter.framework覆盖掉

这里可以对比一下前后变化,多了一个Flutter可执行文件

frc 8e67b3e5c83edcd6780fb0f6a5d7a3d7 - flutter更新遇到ld: framework not found Flutter
覆盖前的Flutte.framework
frc f4123b197158324827e541a326d10b8c - flutter更新遇到ld: framework not found Flutter
覆盖后的Flutte.framework

pp: 其实这个问题是,清理电脑内存的时候,把图中Flutter这个可执行文件删了😄

flutter更新遇到ld: framework not found Flutter