Visit flutter official site 访问Flutter官方网站

Flutter Main page

Flutter install guide

Choose system you are using. You need a macbook if you want to test flutter on ios.

frc 1034cfdb601b442e615e085e80b96f7a - Flutter笔记-安装及开发第一Flutter应用
flutter_install_guide.png

Some problem when installing Flutter 安装过程遇到过的问题

I am an Android engineer, so I have android IDE. After I installed the Flutter and Dart plugin, there is no “New Flutter Project” option in IDE.
I search on the Google. I found this stackoverflow

# flutter upgrade

I run that command twice. At first time, it found two “Android Studio”. The lower version has not install the flutter plugin, so I remove it. At second time, I get following message:

我运行了两次这个命令。第一次发现存在没有安装Flutter插件旧的AS版本,我将其移除。再次运行获得到以下信息:

Upgrading Flutter from /Library/Flutter/flutter...
Already up to date.

Upgrading engine...
Already up-to-date.

Flutter 0.9.4 • channel beta • https://github.com/flutter/flutter.git
Framework • revision f37c235c32 (4 weeks ago) • 2018-09-25 17:45:40 -0400
Engine • revision 74625aed32
Tools • Dart 2.1.0-dev.5.0.flutter-a2eb050044

Running "flutter packages upgrade" in kiipu...              14.6s

Running flutter doctor...
Doctor summary (to see all details, run flutter doctor -v):
[✓] Flutter (Channel beta, v0.9.4, on Mac OS X 10.13.6 17G65, locale zh-Hans-CN)
[!] Android toolchain - develop for Android devices (Android SDK 27.0.3)
    ! Some Android licenses not accepted.  To resolve this, run: flutter doctor --android-licenses
[!] iOS toolchain - develop for iOS devices (Xcode 9.4.1)
    ✗ libimobiledevice and ideviceinstaller are not installed. To install, run:
        brew install --HEAD libimobiledevice
        brew install ideviceinstaller
    ✗ ios-deploy not installed. To install:
        brew install ios-deploy
[✓] Android Studio (version 3.2)
[!] VS Code (version 1.28.2)
[✓] Connected devices (1 available)

! Doctor found issues in 3 categories.

You can find the method to resolve the problem(Solution is also provided in above stackoverflow link ):

从信息可以找到可能的解决方案(stackoverflow 也有人提出此解决方案):

! Some Android licenses not accepted.  To resolve this, run: flutter doctor --android-licenses
# flutter doctor --android-licenses
frc fae1f51a64ac3fc8c077ad63fceab84a - Flutter笔记-安装及开发第一Flutter应用
StackOverFlow

Flutter Github Issue#23086

frc 91e9bc6de3ce877e155ebee048ee8f2e - Flutter笔记-安装及开发第一Flutter应用
flutter_github_issue_23086

Problems when developing the first app:

安装创建第一个Flutter App的官方文档创建引用

在增加新的第三方库时遇到了下面的问题:

# flutter --no-color packages get

Blocked at the state Running “flutter packages get” for a long time and never succeed.
一直卡在flutter packages get很久,并且不成功!

被墙了,你懂得。官方解决方案参考Using-Flutter-in-China

Flutter笔记-安装及开发第一Flutter应用