Mac 安装运行Flutter

最低要求:

操作系统: macOS (64-bit)

磁盘空间: 700 MB (不包括Xcode或Android Studio的磁盘空间).

工具: Flutter 依赖下面这些命令行工具.

bash, mkdir, rm, git, curl, unzip, which

获取Flutter SDK

Flutter官网

环境变量配置

下载的Flutter压缩包解压到目标文件夹(我是解压到了文稿里)

配置环境变量

1.进入home目录:

cd ~/

2.创建.bash_profile文件:

touch .bash_profile

3.打开.bash_profile文件:

open .bash_profile

4.打开记事本配置环境变量和使用镜像

export PUB_HOSTED_URL=https://pub.flutter-io.cn

export FLTTER_STORAGE_BASE_URL=https://storage.flutter-io.cn

export PATH=/Users/ruandongxue/Documents/flutter/bin:$PATH

5.保存并关闭记事本

6.终端运行 source $HOME/.bash_profile刷新当前终端窗口,可以使用echo $PATH来验证flutter/bin是否已在PATH中。

运行flutter doctor查看是否需要安装其他依赖

frc 43bc9225886f094e0cc355b10ef4b591 - Flutter学习  Mac下配置Flutter
运行doctor检查.png

运行后发现缺少很多依赖,按照提示运行即可

frc 4460988ec5c5a4d557017fd7f697af9b - Flutter学习  Mac下配置Flutter
配置成功.png

欢迎留言 互相交流学习

Flutter学习 Mac下配置Flutter